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У статті розглядається проблема сприйняття студентами педагогічних ВНЗ математичних об’єктів та 

їх вивчення у шкільному курсі математики. Розкрито та схарактеризовано психолого-дидактичну систему 
компонентного складу дидактичної системи, а саме: закономірності сприйняття математичних об’єктів, 
психологічні основи зору, знаково-символічна діяльність, компоненти цілісного сприйняття математичних 
об’єктів та показано значення цієї системи для дидактичної підготовки майбутнього вчителя математики. 

Ключові слова: психолого-дидактична система, об’єкт, математичний об’єкт,студент, педагогічний ВНЗ, 
компоненти дидактичної системи. 

 
В статье рассматривается проблема восприятия студентами педагогических вузов математических 

объектов и их изучения в школьном курсе математики. Раскрыто и охарактеризовано психолого-дидактическую 
систему компонентного состава дидактической систем, а именно: закономерности восприятия математических 
объектов, психологические основы зрения, знаково-символическая деятельность, компоненты целостного 
восприятия математических объектов и показано значение данной системы для дидактической подготовки 
будущего учителя математики. 

Ключевые слова: психолого-дидактическая система, объект, математический объект, студент, 
педагогический вуз, компоненты дидактической системы. 

 
This paper addresses the problem of the perception of students of pedagogical universities mathematical objects and 

their school course of study in mathematics. Exposed and are characterized psycho-didactic system component composition 
didactic system, namely the perception of patterns of mathematical objects, psychological basis of vision, the iconic and 
symbolic activity, the components of a holistic perception of mathematical objects and shows the importance of this system 
for didactic training future teachers of mathematics. 

Key words: psychological and didactic system, object, mathematical object, student, university teaching, didactic 
components of the system. 
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АВТОМАТИЗОВАНА СИСТЕМА ДЛЯ ПІДТРИМКИ ПРИЙНЯТТЯ РІШЕНЬ ЩОДО 
ТВОРЧИХ ЗДІБНОСТЕЙ ОСОБИСТОСТІ 

 
В умовах стрімких динамічних змін у різних сферах життя сучасного інформаційного 

суспільства провідною компетенцією фахівця стає спроможність самостійно мислити, творчо 
підходити до реалізації поставлених завдань. Тому державна політика України у сфері освіти 
приділяє досить високу увагу творчості розвитку інтелекту особистості. Творчі здібності 
особистості визначаються не тільки знаннями, вміннями та навичками з окремої дисципліни або 
їх сукупності, а й мотиваційно-творчою активністю і спрямованістю, інтелектуально-логічними 
здібностями, світоглядними та моральними якостями особистості тощо. Серед важливих задач 
сучасної освіти виділяють зокрема задачі виявлення, навчання і виховання талановитих дітей. 

Так, задача виявлення творчих здібностей особистості характеризується невизначеністю 
ситуацій при прийнятті рішення: «Чи має особистість творчі здібності?», значною кількість 
вхідних показників, а також, наявністю у особи, що приймає рішення інформації, яка є 
слабоформалізованою і не може бути врахована при застосуванні лише кількісних методів. 

Однак математичний апарат теорії нечітких множин, запропонований свого часу Л. Заде і 
розвинений протягом останніх десятиріч завдяки дослідженням С. Блюміна [6], А. Кофмана [4], 
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О. Леоненкова [5], О. Ротштейна [7], С. Штовби [8] та інших, дозволяє ефективно розв’язати 
завдання щодо прийняття рішення в умовах невизначеності, нечіткості суб’єктивних оцінок. 

Метою цієї роботи є розроблення автоматизованої системи для підтримки прийняття 
рішень щодо творчих здібностей особистості з урахуванням відповідності елементів бальної і 
вербальної (лінгвістичної) шкал. 

У системі оцінки творчих здібностей особистості визначальна роль належить судженням 
людини. Саме лінгвістичними змінними звикла оперувати людина у повсякденному житті. 
Лінгвістичною називається змінна, значеннями якої можуть бути слова та словосполучення. Усі 
можливі значення лінгвістичної змінної складають терм-множину. Будь-який елемент терм-
множини називається термом і задається нечіткою множиною через функцію належності. 
Функцією належності називають функцію, яка дозволяє для довільного елемента універсальної 
множини обчислити ступінь його належності нечіткій множині. 

У межах нашого дослідження, складовими інтегрального показника творчих здібностей 

особистості ( R ) є такі лінгівістичні змінні: 1P — мотиваційно-творча активність і спрямованість, 

2P — інтелектуально-логічні здібності, 3P — інтелектуально-еврестичні здібності, 4P —

світоглядні властивості (якості), 5P — моральні властивості (якості).  

Лінгвістичні змінні 1P ÷ 5P , R  оцінюються нечіткими термами (усі можливі значення 
лінгвістичної змінної): низький, середній, достаній, високий або у символічному вигляді 

{ }VDSNT ,,,= , що визначені за допомогою функцій належності (рис. 2). Користуючись 
нечіткими термами, сформовані бази знань, фрагмент однієї з них представлений у таблиці 1. 
Кожний рядок бази знань відображає умовні висловлювання, що пов’язують вхідні та вихідну 
змінні. 

Таблиця 1 
Фрагмент бази знань 

 

1P
 2P

 3P
 4P 5P R  

N S N D N N 
S S N N N N 
… … … … … … 
S S S D D S 
D S N S S S 
… …. … … … … 
D N D D D D 
S D V D S D 
… … … … … … 
S V V D V V 
D V V V V V 

 
Для підтримки прийняття рішення щодо творчих здібностей особистості застосуємо 

алгоритм Мамдані. Нечітке виведення Мамдані виконується на наступній базі знань, в якій усі 
значення вхідних та вихідних змінних задані нечіткими множинами: 
( ) mjdRwвагоюзxpxpxp jJnjnjjjjj ,1,

~~~~
2211 ===ΘΘ=Θ= 

, 

де jx1
~

— нечіткий терм, яким оцінюється змінна рi в j-му правилі, mj ,1= ;  
di — заключення j-го правила; m — кількість правил у базі знань;  
Θ  — логічна операція, яка пов’язує фрагменти посилання j-го правила;  
  — нечітка імплікація. 
Для обчислень вводимо наступні позначення: 

— 
( )ij pμ

 — функція належності входу 
[ ]iii ppp ,∈

 нечіткому терму ijx~
, тобто 
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( )
[ ]


∈

=
iii ppp

iijij ppx
,

/~ μ
; 

— 
( )ydjμ

 — функція належності виходу 
[ ]yyy ,∈

 нечіткому терму jd
~

, тобто 
( )

[ ]


∈

=
yyy

djj yyd
,

/
~ μ

. 
Ступінь виконання посилання j-го правила для поточного вхідного вектора 

( )∗∗∗= npppP ,,, 21   розраховуються наступним чином: 
( ) ( ) ( ) ( )( ) mjppppppwP njjjjjjjj .1,21 == ∗∗∗∗ μμμμ 

, 
де рi означає t-норму, якщо в j-му правилі бази знань використовується логічна операція 

ТА 
( )ТАj =Θ

, і відповідає s-нормі при 
( )АБОj =Θ

.  
Результат нечіткого виведення буде виглядати наступним чином: 

( ) ( ) ( )








=

∗∗∗
∗

m

m

d

P

d

P

d

P
y ~,,~,~
~

2

2

1

1 μμμ


. Особливістю цієї нечіткої множини є те, що носієм виступає 

множина нечітких термів { }mddd
~

,,
~

,
~

21  . Для переходу до нечіткої множини на носії 
yy,

 
необхідно виконати операції імплікації та агрегування. 

У результаті логічного виведення по j-му правилу бази знань отримуємо таке нечітке 

значення вихідної змінної у: 
( )( ) mjPdimpd jjj ,1,,

~~ == ∗∗ μ
, де imp — імплікація, яка в нечіткому 

виведенні звичайно реалізується операцією мінімуму, тобто «зрізуються» функція належності 

( )ydjμ
 по рівню 

( )∗Pjμ
. Це має наступний математичний вигляд: 

( ) ( )( )
[ ]


∈

∗∗ =
yyy

djjj yyPd
,

/,min
~ μμ

. 
Загальний же результат логічного виведення по всій базі знань знаходять агрегуванням 

нечітких множин: ( )∗∗∗∗ = mdddaggy
~

,,
~

,
~~

21  , де agg — агрегування нечітких множин, котре 
звичайно реалізують операції максимума. Чітке значення виходу у, що відповідає вхідному 

вектору Р*, визначається через дефазифікацію нечіткої множини y~ . 
Для автоматизації розрахунків використаємо програмний пакет Fuzzy Logic Toolbox 

обчислювальної системи MATLAB, що призначений для проектування та дослідження систем 
на основі теорії нечітких множин. 

Розроблення автоматизованої системи для підтримки прийняття рішення щодо творчих 
здібностей особистості у пакеті розширення Fuzzy Logic Toolbox складається з наступних етапів: 

І етап. Відкрити FIS — редактор за допомогою команди fuzzy. 
ІІ етап. Задати ім’я системи виконав команду меню File>Export>To file редактора FIS. 
ІІІ етап. Ввести параметри системи у головному вікні FIS — редактора.  
IV етап. Вивести у графічне вікно кількість вхідних змінних виконав команду меню 

Edit>Add Variable>Input редактора FIS. 
V етап. Задати ім’я для кожної вхідної та вихідної змінних за допомогою поля Name 

редактора FIS (рис. 1). 
VI етап. Задати діапазон значень для вхідних та вихідних змінних за допомогою поля Range 

редактора FIS. 
VII етап. Перейти у редактор функцій належності виконав команду меню Edit>Membership 

Functions редактора FIS. 
VIII етап. Вилучити встановлені системою MATLAB функції належності виконав команду 

меню Edit>Remove All MFs редактора FIS. 
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Рис. 1. Копія екрана головного вікна автоматизованої системи 

 
IX етап. Вибрати тип функцій належності для окремого терма кожної вхідної та вихідної 

змінних виконав команду меню Edit>Membership Functions, ввести параметри функцій та 
діапазон значень змінних за допомогою поля Params та Range. 

X етап. Ввести назви термів вхідних та вихідної змінних за допомогою поля Name 
редактора функцій належності (рис. 2). 

XI етап. Перейти у редактор правил виконав команду меню Edit>Rules редактора FIS. 
XII етап. Ввести базу правил «Якщо-то», використовуючи поля графічного інтерфейсу 

редактора правил: Connection, Weight та команди: Delete Rule, Add Rule, Change Rule. 
 

 
Рис. 2. Графічний інтерфейс програми редактора функції належності для вхідних і 

вихідної змінних 
 
XIII етап. Вивести вікно щодо виконання висновку виконав команду меню View>Rules 

редактора FIS. 
XIV етап. Виконати нечіткий логічний висновок, вказавши у рядку Input необхідні 

значення вхідних змінних (рис. 3). 
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Рис. 3. Графічний інтерфейс програми після виконання нечіткого висновку для значень 

вхідних змінних [13; 15; 16; 12; 10] 
 
Для аналізу розробленої нечіткої моделі можна скористатись програмою перегляду 

поверхні нечіткого висновку, яка може бути викликана командою меню View> Surface редактора 
функцій належності. 

 

 
Рис. 4. Графічний інтерфейс програми перегляду поверхні нечіткого висновку для 

значень вхідних змінних [13; 15; 16; 12; 10] 
 
Ефективність автоматизованої системи була перевірена на базі Вінницької фізико-

математичної гімназії №17. 
Висновки. Використання розробленої автоматизованої системи у навчальному процесі 

сприяє ефективному та оптимальному розв’язанню завдання підтримки прийняття рішення 
щодо творчих здібностей особистості. 
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У статті розглянута модель визначення рівнів творчих здібностей особистості, в основу якої покладено 

відповідність елементів бальної і вербальної (лінгвістичної) шкал. Розроблена автоматизована система для 
підтримки прийняття рішень щодо творчих здібностей особистості за допомогою програми Fuzzy Logic Toolbox 
системи MATLAB. 

Ключові слова: нечітка множина, функція належності, лінгвістична змінна, творчі здібності. 
 
В статье рассмотрена модель определения уровней творческих способностей личности, в основу которой 

положено соответствие элементов балльной и вербальной (лингвистической) шкал. Разработанная 
автоматизированная система для поддержки принятия решений относительно творческих способностей 
личности с помощью программы Fuzzy Logic Toolbox системы MATLAB. 

Ключевые слова: нечеткое множество, функция принадлежности, лингвистическая переменная, 
творческие способности. 

 
In this paper the model determine levels of creative abilities of the individual, which is based on line items and scoring 

verbal (linguistic) scales. Developed an automated system to support decision-making on the creative abilities of the 
individual using the Fuzzy Logic Toolbox of MATLAB. 

Key words: fuzzy set, membership function, linguistic variable creativity. 
 
 
 
 

УДК 378, 808.51  
 

О.Б. Залюбівська45 
м. Вінниця, Україна

 
ПЕДАГОГІЧНА МОДЕЛЬ ФОРМУВАННЯ РИТОРИЧНОЇ КУЛЬТУРИ МАЙБУТНІХ 

ВИКЛАДАЧІВ ТЕХНІЧНИХ УНІВЕРСИТЕТІВ 
 
Постановка проблеми. Масштабне завдання формування риторичної культури (далі — 

РК) майбутніх викладачів технічних університетів — яке розуміємо як цілеспрямований процес 
і результат їхнього опанування риторичними знаннями, набуття риторичних умінь, утворення 
професійно важливих риторичних якостей особистості, засвоєння й прийняття риторичних 
цінностей та риторичного ідеалу, утворення спрямованості на риторичне самовдосконалення — 
зумовлює пошук дидактичних можливостей його реалізації. Педагогічна теорія і практика 
свідчать, що найефективнішим шляхом вирішення поставленого завдання є педагогічне 
моделювання.  

Мета статті — описати структуру та зміст педагогічної моделі формування РК майбутніх 
викладачів технічних університетів.  

Дослідження й публікації. Ефективність моделювання в педагогіці доводять І. Підласий, 
П. Підкасистий, А. Ашеров, О. Козирєва, Є. Лодатко, В. Міхєєв та ін. Воно дозволяє 
оптимізувати структуру навчального матеріалу; поліпшити планування навчального процесу; 
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